История изменений

 Следующая

Изменения в версии 4.20 от 12.02.2013

1. Очень значительно улучшены алгоритмы раскроя:

- уменьшена площадь неделовых отходов (в среднем на 10%);

- увеличено качество карт раскроя практически на всех тестах;

- значительно улучшен алгоритм получения деловых отходов;

- значительно улучшен алгоритм раскроя деловых отходов;

- улучшена экономия целых листов - за счет раскроя деловых отходов;

- еще больше уменьшена суммарная длина всех рабочих резов.

ПОЯСНЕНИЕ:

За 7 месяцев разработки - было _перепробовано_ более 50-ти

математических алгоритмов (в том числе и очень сложных),

которые бы могли помочь в росте качества карт раскроя. И это удалось!

Кроме того, более 20-ти новых математических алгоритмов пришлось

разработать – для уменьшения времени работы (без потери качества).

Так как предыдущая версия 4.19 превосходила Opty-Way, то выпущенная

версия 4.20 – претендует на первое место в мире по экономии материала.

2. Добавлены новые настройки программы:

АЛГОРИТМЫ РАСКРОЯ

1). Увеличить время расчета-> (Нет/в 1.5 раз/в 2 раза/в 2.5 раз).

2). Максимальное время, если заготовок не больше -> (100-300).

ПОЯСНЕНИЕ:

Настройка 1 – позволяет уменьшить время расчета карт раскроя.

Настройка 2 – используется в случае, если задано уменьшение времени расчета.

3. После установки новой версии – программа теперь автоматически скрывает:

– устаревшие настройки программы;

– устаревшие документы, если они не используются.

Для возможности использования устаревших настроек (или документов)

в программу была добавлена новая настройка:

ВНЕШНИЙ ВИД ПРОГРАММЫ

= Скрыть устаревшие настройки программы -> (Да,Нет).

Изменения в обновлении программы от 01.07.2012

1. Для универсальных документов наклеек:

- "Наклейки заготовок (лист формата A4)"

- "Наклейки заготовок (принтер этикеток)"

исправлен вывод ГОСТ - в связи с изменениями:

1) старый ГОСТ 24866-99 - действовал до 01.07.2012

2) новый ГОСТ Р 54175-2010 - действует с 01.07.2012

Изменения в обновлении программы от 15.06.2012

1. Решена проблема автоматического добавления в программу: стеклопакетов

из двух и более типов материалов - без повторного ввода данных.

ПОЯСНЕНИЕ (как это работает):

1) вводим (в заказе) первый тип материала и заготовки по нему;

2) добавляем название 2-го типа материала (в этом же заказе);

3) добавляем (вручную!) первую заготовку по второму материалу,

при этом:

3.1) программа проанализирует предыдущие типы материалов и стеклопакеты;

3.2) предложит _автоматически_ добавить недостающие части стеклопакетов.

РЕКОМЕНДУЕТСЯ: (в заказе)

Сначала заносить материал "Не обычное стекло" (например, "И-cтекло"),

а уже затем - "Стекло" (особенно если стеклопакет состоит из 3-х разных

материалов). Для двух разных материалов - порядок занесения любой.

2. Добавлена новая настройка программы:

СПРАВОЧНИК МАТЕРИАЛОВ

= Вводить максимальную длину реза -> Да.

ПОЯСНЕНИЕ:

Настройку можно задать в случае необходимости ограничить

максимальную длину реза - по конкретному типу материала.

Изменения в обновлении программы от 31.05.2012

1. Добавлены:

- импорт в программу текстового штрих-кода заготовок;

- отображение штрих-кода "Code 128" на наклейках и в документах;

для последующего считывания штрих-кода сканером.

ПОДРОБНЕЕ - в разделе инструкции к программе:

[Настройка программы] => [Импорт заготовок (из Excel)].

Зачем нужен штрих-код:

http://global-katalog.ru/item30086.html

http://40.com.ua/a_index/_whybarcode.htm

2. При отображении карт раскроя - на экране и при печати

добавлен вывод координат резов внутри каждой заготовки.

Это можно изменить с помощью настройки программы:

ПРОСМОТР КАРТ РАСКРОЯ

= Выводить координаты резов внутри заготовок -> (Да,Нет).

ЗАМЕЧАНИЕ:

По умолчанию - эта настройка включена всегда, кроме случая

формирования выходных данных для автоматического станка резки.

Изменения в обновлении программы от 01.04.2012

1. Для универсальных документов наклеек:

- "Наклейки заготовок (лист формата A4)"

- "Наклейки заготовок (принтер этикеток)"

были добавлены новые настройки программы:

ДОКУМЕНТ "НАКЛЕЙКИ ЗАГОТОВОК"

1). Выводить дату изготовления (Да,Нет).

2). Выводить ГОСТ 24866-99 (Да,Нет).

3). Оставить место для штампа (Да,Нет).

ЗАМЕЧАНИЕ:

Вывод даты изготовления - рекомендуется подключить,

т.к. на это обратила внимание контролирующая инспекция.

2. Новая версия полностью поддерживает:

увеличение размеров шрифта в выводимых списках на экране,

согласно заданному масштабу увеличения в Microsoft Windows.

При этом на ЖК-мониторе - лучше выставить родное разрешение

экрана, рекомендованное фирмой-производителем монитора.

ПОЯСНЕНИЕ:

Увеличить размер шрифта - можно с помощью

следующих настроек операционной системы:

[Пуск] => [Панель управления] => [Экран]:

1) Windows XP: [Параметры] => [Дополнительно] => [Масштаб].

2) Windows 7: [Другой размер шрифта] => [Масштаб].

3) Windows 98: [Настройка] => [Дополнительно] => [Размер шрифта].

3. Добавлена новая информация в инструкцию к программе:

[Настройка программы] => [Настройка экрана ЖК-монитора]

ОБРАТИТЕ ВНИМАНИЕ:

В описанной документации собраны очень полезные советы!

В том числе - это позволит Вам сделать экранный текст более четким и легче его читать в течение длительного времени без напряжения глаз и умственной усталости.

4. При запуске и выполнении расчета карт раскроя:

программа отключает заставку (Screen Saver) в Windows,

чтобы получить результаты расчета - как можно быстрее.

5. Исправлено отображение карт раскроя:

1). Увеличена скорость отображения карт раскроя - до 10-20%

на отдельных картах с большим числом заготовок.

2). Изменена штриховка деловых отходов на экране:

теперь она выведена более темной, специально для ЖК-мониторов

с матрицей FN, т.к. ранее ее плохо было видно (в т.ч. на ноутбуках).

Изменения в обновлении программы от 25.01.2012

1. Добавлен импорт заготовок - при раскрое листового стекла

из программы 'Суперокна' (два разных формата MS Excel).

Новый импорт заготовок можно подключить настройкой:

ЗАГОТОВКИ

= Формат импорта заготовок -> Суперокна

ПОЯСНЕНИЕ:

1) импорт заготовок возможен из разделов "Заказы" и "Тип материала";

2) для приема данных из раздела "Заказы" - названия типов материалов

должны совпадать в обоих программах.

2. При вводе листов на складе - добавлено предупреждение

о рекомендации задания Длины листа больше Ширины листа:

т.к. этом случае - масштаб вывода карт раскроя будет увеличенным!

Изменения в обновлении программы от 12.12.2011

1. Изменен импорт заготовок:

добавлена поддержка импортируемых файлов в MS Excel 2007,2010:

- с новыми расширениями файлов *.XLSX, *.XLSM, *.XLSB;

- с дополнительными расширениями *.XL* .

2. Добавлена возможность параллельной работы в MS Excel (вне программы) - во время формирования отчета.

Изменения в обновлении программы от 25.10.2011

1. Изменены документы:

1). Наклейки деловых отходов (лист формата A4).

2). Наклейки заготовок (лист формата A4).

ПОЯСНЕНИЕ (список изменений):

- добавлена печать на бумаге с надрезами - без полей отступа от края листа;

- улучшено масштабирование документа по высоте страницы.

Вышла новая версия 4.19 от 08.10.2011


Сравнение версий 4.19 и 4.20

 Предыдущая Следующая

Сравнительные результаты тестирования (на листах 3210x2250):

=== Cut ===

Тесты 1,2,3:

http://autocut.ru/tmp/test/test1.xls

http://autocut.ru/tmp/test/test2.xls

http://autocut.ru/tmp/test/test3.xls

Методика тестирования:

http://autocut.ru/tmp/test/test.doc

Полные документы "Статистика раскроя заказов" (в архиве):

http://autocut.ru/tmp/test/testfull.rar

Вывод: на 10% уменьшена площадь неделовых отходов.

=== Cut ===

По сравнению с Opty-Way по экономии материала:

площадь неделовых отходов меньше на 12-15% (на листах 3210x2250).


Настройки программы (новые)

1. АЛГОРИТМЫ РАСКРОЯ

1). Увеличить время расчета (Нет/в 1.5 раз/в 2 раза/в 2.5 раз) - настройка дает возможность увеличить время расчета карт раскроя и (соответственно) повысить коэффициент использования материала.

2). Максимальное время, если заготовок не больше (100/…/150/…/300) – настройка используется в случае, если задано уменьшения времени расчета (предыдущей настройкой). Пояснение: Если при расчете карт раскроя будет задано общее число заготовок, не превышающее значение этой настройки, то - программа будет максимально увеличивать время расчета (в 2.5 раз), независимо от значения настройки увеличения времени.

2. СПРАВОЧНИК МАТЕРИАЛОВ

1). Вводить максимальную длину реза (Да/Нет) - настройка позволяет задать ограничение “максимальная длина реза” для конкретного наименования материала.

3. ЗАГОТОВКИ

1). Импортировать штрих-код заготовок (Да/Нет) - позволяет импортировать для каждой заготовки (из внешнего файла) текстовый штрих-код (до 13 символов). Эта информация будет отображаться в документах:

“Наклейки заготовок …”, “Заготовки”, “Стеклопакеты”, “Стеклопакеты № 2”.

4. ПРОСМОТР КАРТ РАСКРОЯ

1). Выводить координаты резов внутри заготовок (Да/Нет) - по умолчанию выводятся, кроме случая формирования данных для автоматических станков резки.

5. ДОКУМЕНТ "НАКЛЕЙКИ ЗАГОТОВОК"

1). Выводить дату изготовления (Да/Нет) - позволяет вывести дату заказа на наклейке, что рекомендуется - т.к. контролирующая инспекция задавала лишние вопросы предприятию у которого этого не было

2). Выводить ГОСТ Р 54175-2010 (Да/Нет).

3). Оставить место для штампа (Да/Нет) - позволяет оставить пустое место на наклейке, чтобы поставить штамп. Если для штампа на наклейке остается “мало места по высоте”, то подключите настройку:

“Выводить наименование заказчика -> Да”.

6. ДОКУМЕНТ "СТЕКЛОПАКЕТЫ № 2”

1). Выводить штрих-код (Да/Нет) - позволяет разрешить/запретить вывод в документе штрих-кода.

7. ВНЕШНИЙ ВИД ПРОГРАММЫ

1). Скрыть устаревшие настройки программы (Да/Нет) – настройка позволяет скрыть (не показывать) устаревшие или не используемые настройки и документы.


Импорт заготовок (из Excel)

Импорт заготовок (из формата Excel)

 Предыдущая Следующая

Настройка импорта заготовок

Операцию импорта заготовок из файла Microsoft Excel можно подключить - из верхнего меню “Сервис” -> “Настройки” с помощью изменения в подразделе ЗАГОТОВКИ настроек:

Подключить импорт заготовок -> Да.

Формат импорта заготовок -> Excel.

Операция будет доступна из верхнего меню “Входные данные” -> “Импорт заготовок”.

С помощью этой операции можно импортировать и обычные текстовые файлы (подробнее об этом - в конце раздела).

Формат импортируемого файла Microsoft Excel

Импортируемый файл с принимаемыми заготовками должен иметь колонки:

1) порядковый номер заготовки (1,2,...);

2) длина заготовки;

3) высота заготовки;

4) количество заготовок;

5) признак разрешения поворота заготовки (пусто или цифры 1,0 или Да,Нет);

6) примечание;

7) код типа материала (любые целые числа - могут идти не по порядку);

8) наименование типа материала;

9) имя стеклопакета;

10) количество стеклопакетов;

11) штрих-код (текст выводимый штрих-кодом Code 128 - не более 13-ти символов, подробнее - ниже).

Обязательные колонки в файле только 1-4, все остальные могут отсутствовать.

Если у Вас стеклопакеты состоят из двух материалов (не больше!), то достаточно импортировать только стеклопакеты основного материала (обычно “Стекло 4 мм”), при этом:

- колонки 7,8 можно не заполнять (так как импортируется единственный материал);

- эти же стеклопакеты в других материалах - программа добавит автоматически при попытке добавить вручную самую первую (новую) заготовку в каждом типе материала отдельно.

При пустых значениях в колонках:

4) количество заготовок - это поле может быть автоматически рассчитано в случае:

- если (в колонке 9) задано имя стеклопакета из одного типа материала;

- если (в колонке 10) указано количество стеклопакетов;

5) признак разрешения поворота - поворот всех заготовок будет разрешен;

6) примечание - все примечания заготовок не будут заданы;

7) код типа материала - в файле содержится только 1 тип материала;

8) наименование типа материала - не используется при пустых значениях в колонке 7;

9) имя стеклопакета - все имена стеклопакетов заготовок не будут заданы;

10) количество стеклопакетов - все количества стеклопакетов не будут заданы.

Особенности входного файла для импорта:

- общее число заготовок должно быть не менее 2-х;

- начало данных (номер 1-й заготовки) - произвольный номер строки;

- все заготовки идут в файле подряд, без пустых строк;

- заголовки колонок не обязательны, т.к. при импорте заготовки распознаются по порядковым номерам.

В один тип материала можно импортировать несколько разных файлов - в этом случае все заготовки будут добавлены в этот тип материала.

Обработка ошибок в полях принимаемого файла:

1) при ошибках в (Длине,Высоте,Количестве) заготовок: они сохраняются нулевыми;

2) при ошибке в (Признаке разрешения поворота): в примечании заготовки сохраняется текст: “ОШИБКА ПОВОРОТА”;

3) при превышении (Примечанием) заготовки максимальных (15-30) символов и при отсутствии ошибки в (Признаке разрешения поворота): в конце примечания заготовки сохраняется текст: “..” (две точки);

4) при ошибке в (Имени стеклопакета): в имени стеклопакета заготовки сохраняется текст: “ОШИБКА”;

5) при ошибке в (Количестве стеклопакетов):

- если оно не соответствует имени стеклопакета - в имени стеклопакета сохраняется текст: “ОШИБКА”;

- иначе это поле сохраняются нулевым;

6) общее количество обнаруженных ошибок в каждой из колонок файла - выводится на экран;

7) если общее число ошибок превышает число заготовок - файл не принимается.

ЗАМЕЧАНИЕ:

максимальное число символов в примечании заготовки можно увеличить с помощью настройки программы (в подразделе ЗАГОТОВКИ):

Максимальная длина примечания -> (15-30 символов).

Эта настройка позволяет увеличить длину примечания при импорте и в документах "Наклейки заготовок", однако в картах раскроя - примечание всегда выводится не более 15 символов:

>15 -> (2 первых символа)+".."+(11 последних символов примечания).

Импорт имени стеклопакета

Если в программе раскроя стекла была задана настройка (в подразделе ЗАГОТОВКИ):

Вводить имя стеклопакета -> Да,

то вводимые для каждой заготовки имена стеклопакетов можно импортировать из 9-й колонки файла.

Импорт количества стеклопакетов/изделий

Если в программе раскроя была задана настройка (в подразделе ЗАГОТОВКИ):

Вводить количество стеклопакетов/изделий -> Да,

то вводимое для каждой заготовки количество стеклопакетов/изделий можно импортировать

из 10-й колонки файла.

При этом в программе раскроя станет возможно:

- формировать документы "Наклейки заготовок" по количеству стеклопакетов/изделий.

Импорт штрих-кода

Если в программе раскроя была задана настройка (в подразделе ЗАГОТОВКИ):

Импортировать штрих-код заготовок -> Да,

то штрих-код для каждой заготовки можно импортировать из 11-й колонки файла.

ЗАМЕЧАНИЕ:

В некоторых сканерах может быть ограничено - количество читаемых символов,

например мне известен случай - когда сканер считывал только до 11-ти символов.

При задании числа символов 12 или 13 - этот сканер не распознавал штрих-код.

Информация по формату штрих-кода Code 128:

http://tradepilot.ru/goods-marks/code128

http://axiger.livejournal.com/12146.html

http://ru.wikipedia.org/wiki/Code_128

Зачем нужен штрих-код:

http://global-katalog.ru/item30086.html

http://40.com.ua/a_index/_whybarcode.htm

http://sitmag.ru/article/technology/2006_10_A_2007_02_09-14_30_45/

http://gs1kg.org/Content.aspx?ps=faq

http://cleverence.ru/site.aspx?page=WarehouseBarcoding-01

Текстовый формат файла - для импорта заготовок

Заготовки можно импортировать в этой операции - и из обычного текстового файла, который должен иметь вид:

1) файл должен иметь расширение .XLS ;

2) поля в файле должны быть разделены символом ТАБУЛЯЦИЯ;

3) порядок полей в каждой строке файла - такой же, как и во входном файле Microsoft Excel;

4) при этом все текстовые строки (примечаний и наименований стеклопакетов) необходимо обязательно задавать в виде строки:

=”текст”

где текст - это содержимое текстовой строки.


Импорт заготовок (из Суперокна)

Импорт заготовок (из программы Суперокна - в формате Excel)

 Предыдущая Следующая

Настройка импорта заготовок

Операцию импорта заготовок из программы Суперокна можно подключить - из верхнего меню “Сервис” -> “Настройки” с помощью изменения в подразделе ЗАГОТОВКИ настроек:

Подключить импорт заготовок -> Да.

Формат импорта заготовок -> Суперокна.

Операция будет доступна из верхнего меню “Входные данные” -> “Импорт заготовок”.

Прием данных

1. Импорт из раздела “Заказы” (рекомендуется)

1). Введите новый заказ (из раздела “Заказы” нажать клавишу INSERT или кнопку Добавить).

2). [Верхнее меню] -> [Входные данные] -> [Импорт заготовок].

Для успешного приема всех данных - названия типов материалов должны совпадать в обоих программах.

2. Импорт из раздела “Тип материала”

1). Введите новый заказ (из раздела “Заказы” нажать клавишу INSERT или кнопку Добавить).

2). Перейдите в раздел “Тип материала” и введите новый тип материала.

3). [Верхнее меню] -> [Входные данные] -> [Импорт заготовок].

4). Выбрать (из предложенного списка) тип материала – для импорта только этих заготовок.

Этот режим импорта позволяет:

- импортировать из файла - заготовки только одного типа материала;

- добавить заготовки к уже существующим (в типе материала) заготовкам;

- добавить заготовки в уже существующий (не пустой) заказ.

Допустимые форматы импортируемых файлов Microsoft Excel

1. Список заготовок

- колонка 3 – примечание заготовки;

- колонка 5 – тип материала;

- колонка 8 – размеры заготовки;

- колонка 11 – количество заготовок.

В этом случае данные о заготовках - начинаются во входном файле со строки 1.

2. Группировка заготовок по cчетам

- колонка 2 – примечание заготовки;

- колонка 8 – тип материала;

- колонка 12 – размеры заготовки;

- колонка 17 – количество заготовок.

В этом случае данные о заготовках - начинаются во входном файле со строки 4.


Настройка экрана ЖК-монитора

При наличии ЖК-монитора (жидкокристаллического монитора) - необходимо его правильно настроить:

1. В свойствах экрана выставить рекомендованные производителем разрешение экрана (обычно максимальное) и частоту обновления (обычно 60 Гц), иначе качество изображения может существенно пострадать.

Пояснение: в отличие от ЭЛТ-мониторов, ЖК имеют одно фиксированное разрешение, остальные достигаются интерполяцией. Именно при этом фиксированном разрешении - как раз и достигается наилучшее изображение.

2. Cнизить яркость до комфортного значения. Большинство производителей по умолчанию выставляют ее на максимум, от чего уже через 15 минут работы с устройством может появиться сильная усталость глаз.

3. Увеличить размер отображаемого шрифта текста - с помощью настроек:

[Пуск] => [Панель управления] => [Экран]:

1) Windows XP: [Параметры] => [Дополнительно] => [Масштаб].

2) Windows 7: [Другой размер шрифта] => [Масштаб].

3) Windows 98: [Настройка] => [Дополнительно] => [Размер шрифта].

При этом можно выбрать свой вариант масштаба - с точностью 1% (в интервале от 100% до 500%), для этого нажмите на масштабной линейке левую кнопку мыши и не отпуская ее - перетаскивайте линейку (вправо или влево), передвигая мышь. Когда будет достигнут нужный % - просто отпустите кнопку мыши.

4. Настроить сглаживание экранных шрифтов ClearType.

ClearType – это технология отображения компьютерных шрифтов на ЖК-мониторах, при использовании которой они выглядят четкими и гладкими. ClearType делает экранный текст более четким, и следовательно, его легче читать в течение длительного времени без напряжения глаз и умственной усталости. Подробнее об этом - ниже.

Далее - подробно описаны настройки экрана для каждой из операционных систем.

Настройка экрана в Windows XP

1. Подключение экранных шрифтов ClearType

[Экран] => [Оформление] => [Эффекты] => [x] Применить следующий метод сглаживания экранных шрифтов

и в окошке ниже - из выпадающего списка выбрать ClearType.

2. Настройка сглаживания экранных шрифтов ClearType (настройка толщины шрифта)

В операционной системе такая возможность отсутствует, но для этого есть бесплатная утилита от Microsoft - ClearType Tuner PowerToy:

http://www.microsoft.com/typography/ClearTypePowerToy.mspx

После её установки в “Панель управления” появляется апплет ClearType. Запускаем его, включаем опцию “Turn On ClearType”, нажимаем кнопку “Start Wizard” и визуально подбираем параметры. После этого во всех программах будет использоваться сглаживание шрифтов. Можно также настроить ClearType без установки этой программы - с помощью онлайновой утилиты:

http://www.microsoft.com/typography/ClearType/tuner/Step1.aspx

3. Увеличение размера значков - на рабочем столе

[Экран] => [Оформление] => [Эффекты] => [x] Применять крупные значки.

4. Увеличение размера шрифта текста - для подписей к значкам на рабочем столе

[Экран] => [Оформление] => [Размер шрифта] => Обычный / Крупный / Гигантский.

5. Очень интересные статьи по настройке Windows XP (для специалистов)

http://xpsite.net/optim/index.php?id=8sec

Настройка экрана в Windows 7

1. Настройка сглаживания экранных шрифтов ClearType (настройка толщины шрифта)

[Экран] => [Настройка текста ClearType].

2. Как увеличить шрифт подписей значков - без увеличения самих значков

[Пуск] => [Панель управления] => [Оформление и персонализация] => [Персонализация] => [Цвет и оформление окон] => [Дополнительные настройки оформления]: в списке выбрать Значок и для него выбрать размер шрифта.

3. Изменение размера значков на рабочем столе

Выделяем любой значок на рабочем столе левой кнопкой мышки, нажимаем клавишу “Ctrl” и, вращая колесико мышки, устанавливаем нужный размер. Все готово, данный размер будет сохранен.

4. Как правильно настроить цвета на ЖК-мониторе - для улучшения изображения

http://www.ardikon.ru/color/kak-pravilno-nastroit-lcd-monitor.html

Замечание: настройка в разное время суток может привести к различным результатам! Обратите внимание на картинки (с цифрами) в начале статьи: поздним вечером или ночью - цифры на белом фоне станут видны немного хуже, а на черном фоне - намного лучше.


Настройка станка резки

Формирование выходных данных для станка

Для получения выходных данных для станка резки - необходимо из верхнего меню “Сервис” -> “Настройки” - задать следующие значения настроек:

СТАНОК РЕЗКИ

1. Формировать карты раскроя для станка -> Да.

2. Формат выходных данных для станка -> (формат данных для вашего станка резки).

Для станков разрабатываемых ЗАО “Оптиком” - устанавливается формат XLS.

Если в указанном списке нет формата для Вашего станка ЧПУ, то можно написать нам и мы доработаем программу раскроя - под Ваш станок резки. Или же Ваша организация может собственными силами адаптировать нашу программу под любой станок: для этой цели предусмотрены форматы TXT, XLS.

После расчета карт раскроя для нового заказа - файлы для станка резки автоматически будут сохранены в поддиректорию DAT_REZ, которая расположена внутри директории установки программы. Любой пересчет карт раскроя (при изменении данных заказа) - также приведет к изменению файлов для станка.

При установке программы раскроя в директорию по умолчанию - данные для станка можно найти в директории:

1. Для полной версии программы:

C:\Program Files\AutoNest\DAT_REZ\

2. Для демонстрационной версии программы:

C:\Program Files\AutoDemo\DAT_REZ\

ЗАМЕЧАНИЕ:

Порядок выполнения резов на станке оптимизирован таким образом, чтобы сократить не только рабочий, но и холостой ход резака - что позволяет сократить общее время резки любой карты раскроя на станке.

Дополнительные настройки для резки стекла

В зависимости от точности позиционирования станком реза, легкости материала и т.д. - в программе предусмотрены следующие специальные настройки:

СТАНОК РЕЗКИ

1. Отступ от перпендикулярного реза -> (0 мм - 5 мм).

2. Отступ от края листа -> (0 мм - 5 мм).

Первая настройка позволяет выдержать определенное расстояние недореза. В этом случае линия реза будет не доходить до ее окончания - на указанное этой настройкой расстояние, чтобы полностью исключить “стрелки” в местах пересечения резов - по которым дальше может пойти трещина в процессе ломки стекла.

Вторая настройка позволяет начинать рез не от самого края листа, а отступив от него заданное расстояние. Это позволяет уменьшить силу “толкания листа” резаком, что наиболее актуально при резке легких листов стекла.

Универсальные текстовые форматы XLS,TXT для станка резки

Каждый файл формата XLS или TXT - содержит информацию о резке только одной карты раскроя. В случае резки нескольких совершенно одинаковых карт раскроя - эти карты раскроя также будут сохранены в различных файлах.

В каждой строчке этих файлов - выводится 4 числа (координаты резов): X1,Y1,X2,Y2.

Резак опускается в координате (X1,Y1) и режет до координаты (X2,Y2),

затем поднимается и переходит к резке следующего реза (в следующей строке файла).

ЗАМЕЧАНИЕ:

Файл Microsoft Excel (XLS) - это обычный текстовый файл, данные в котором разделены символом табуляция. Программа может формировать и более полный формат файла (TXT), где идет расшифровка листов и кромок.


Настройка работы по сети

Программу раскроя можно настроить таким образом, чтобы запуская ее с различных компьютеров - работать с общей базой данных. Такая настройка возможна только в полной версии программы (с электронным ключом). Однако запустить программу вы сможете лишь на тех компьютерах в сети, где подключен электронный ключ.

Краткое описание настройки программы (для работы по сети)

В директории программы есть файл настроек AUTONEST.CFG первая строчка в котором - это путь к сетевой базе данных программы. Например если первую строчку в этом файле изменить на такую:

Z:\AUTONEST.DBF\

то в папку Z:\AUTONEST.DBF\

необходимо перенести директорию (сетевой базы данных) программы:

C:\Program Files\AutoNest\DBF_NET\

удалив саму папку "DBF_NET", чтобы не было путаницы о реальном месте хранения данных. Такие изменения необходимо выполнить на каждом компьютере, где запускается программа.

Полное описание настройки программы (для работы по сети)

Опишем настройку программы для работы по сети - для двух компьютеров. Пусть:

- на первом компьютере - установлена последняя версия программы и рабочая база данных;

- на каждом из 2-х компьютеров подключен общий сетевой диск ( Z: ).

Для работы программы по сети - необходимо сделать следующее:

1. На первом компьютере - где уже установлена программа и данные:

1). Перенести данные на сетевой диск:

Директорию: C:\Program Files\AutoNest\DBF_NET\

Переместить в: Z:\DBF_NET\

2). Заменить внутри текстового файла путь к данным:

В файле: C:\Program Files\AutoNest\AUTONEST.CFG

Изменить первую строчку "DBF_NET\" на: Z:\DBF_NET\

3). Запустить программу и убедиться, что она работает.

2. На втором компьютере:

1). Установить программу с дистрибутивного диска и затем установить самое последнее обновление.

2). Проверить, что программа (на втором компьютере) запускается и успешно работает.

3). Удалить директорию:

C:\Program Files\AutoNest\DBF_NET\

4). Заменить внутри текстового файла путь к данным:

В файле: C:\Program Files\AutoNest\AUTONEST.CFG

Изменить первую строчку "DBF_NET\" на: Z:\DBF_NET\

5). Запустить программу и убедиться, что она работает и что данные программы - совпадают с данными на первом компьютере (кроме настроек программы).

6). Для одинаковых настроек программы на втором компьютере:

- их можно изменить из программы вручную - из верхнего меню “Сервис” -> “Настройки”;

- или можно с 1-го компьютера на 2-й компьютер - скопировать и заменить файлы настроек:

C:\Program Files\AutoNest\CONSTANT.DBF

C:\Program Files\AutoNest\CONSTANT.FPT


Раскрой листов с рисунком

Для раскроя листов материала с рисунком - лучше поступить так:

1. [Верхнее меню] => [Сеpвис] => [Настройки]:

СПРАВОЧНИК МАТЕРИАЛОВ

Вводить запрет поворота всех заготовок -> Да.

2. [Верхнее меню] => [Входные данные] => [Справочник материалов]:

Добавить новый материал (клавишей INSERT):

Наименование материала: Стекло с рисунком

Поворот всех заготовок: Запрещен

PS. Имя материала - можно задать любым (которое больше нравится).

3. [Верхнее меню] => [Входные данные] => [Листы на складе]:

=> занести листы (с рисунком) на склад:

Для раскроя листов с рисунком - при запрете поворота заготовок:

Длина, ширина листа - это длина (по оси X), выcота (по оси Y) листа.

Длина, ширина заготовки - длина (по оси X), выcота (по оси Y) заготовки.

Рекомендуется - для лучшего увеличения при печати карт раскроя:

задавать [длину листа] > [ширины (высоты) листа], но это не обязательно:

просто при задании листа наоборот - масштаб карт раскроя будет меньше.

4. В новом Заказе - в разделе "Тип материала":

при вводе материала выбрать новый материал -> "Стекло с рисунком".

PS. При вводе всех заготовок - их поворот будет всегда запрещен

для материала "Стекло с рисунком"

(и невозможно будет разрешить поворот у какой-нибудь заготовки).

Если существуют заготовки (хотя бы одна) - для которой запрещать поворот не нужно – не устанавливайте запрет на поворот заготовок в пункте 2

(или временно его измените), т.к. в этом случае – коэффициент заполнения будет выше.

Кроме того:

в одном заказе - можно задать любое число типов материалов

(например, раскраивать обычное стекло и стекло с рисунком).


Раскрой разных материалов

Для добавления нового типа материала – необходимо выполнить следующие действия:

1. Войти в справочник материалов

[Верхнее меню] => [Входные данные] => [Справочник материалов].

2. Добавить в этот справочник - новый материал:

имя введенного материала – может быть любым.

3. Занести на склад листов - листы этого типа материала:

[Верхнее меню] => [Входные данные] => [Листы на складе] => [нажать клавишу INSERT].

Наименование нового материала – выбрать при вводе.

4. В новом Заказе - в разделе "Тип материала":

при вводе материала выбрать новый материал.

В одном заказе можно занести - любое число разных материалов.

5. При импорте файла заготовок с несколькими типами материалов

этот файл импортируется отдельно - в каждый тип материала.

То есть c заказа - переходим в раздел "Тип материала":

1) встаем на первый материал и импортируем файл заготовок;

2) встаем на второй материал и импортируем этот же файл;

и т.д.

6. После расчета карт раскроя по заказу - каждый тип материала

раскраивается отдельно.


Раскрой термостойкого стекла

 Предыдущая

Для добавления нового типа материала – термостойкое стекло

необходимо выполнить следующие действия:

1. Войти в справочник материалов

[Верхнее меню] => [Входные данные] => [Справочник материалов].

2. Добавить в этот справочник - новый материал: "И-стекло" (без кавычек).

Имя введенного материала - может быть любым.

3. Занести на склад листов - листы этого типа материала:

[Верхнее меню] => [Входные данные] => [Листы на складе] => [нажать клавишу INSERT].

Наименование нового материала – выбрать "И-стекло".

4. В новом Заказе - в разделе "Тип материала":

при вводе материала выбрать материал (из списка).

В одном заказе можно занести - любое число разных материалов.

Например, в одном заказе можно добавить 2 типа материала:

1) И-стекло 4 мм - если в этом заказе используется термостойкое стекло;
2) Стекло 4 мм.

5. При занесении стеклопакета из обычного и термостойкого стекла

это обязательно указывается после размеров стекла - в формуле

стеклопакета:

4И-16-4 => обозначает: 4И - это "И-стекло 4 мм", 4 - это "Стекло 4 мм".

6. При импорте файла заготовок с несколькими типами материалов

этот файл импортируется отдельно - в каждый тип материала.

То есть c заказа - переходим в раздел "Тип материала":

1) встаем на материал "И-стекло 4 мм" (если есть) и импортируем файл;

2) встаем на материал "Стекло 4 мм" и импортируем этот же файл;

и т.д.

7. После расчета карт раскроя по заказу - каждый тип материала

раскраивается отдельно.


Тип материала

Обратите внимание на важность порядка занесения типов материалов в новом заказе:

выборка по заказу Заготовок/Листов/Карт раскроя/Деловых отходов - автоматически установит сортировку их списка - по порядку занесения типов материалов.

При переходе с Типа материала на Заготовки/Листы/Карты раскроя/Деловые отходы - будет выведена информация только по этому типу материала.

Для изменения толщины реза по уже добавленному типу материала:

1) измените толщину реза в Справочнике материалов;

2) измените входные данные (для удаления полученных ранее карт раскроя);

3) выполните расчет карт раскроя по заказу или типу материала.

ПОЯСНЕНИЕ:

при пересчете карт раскроя толщина реза будет взята из Справочника материалов.

Описание функциональных клавиш:

ENTER - редактировать запись

INSERT - добавить новую запись

F5 - перейти на заготовки

F8 - удалить запись

CTRL+ENTER - пометить/убрать пометку

CTRL+S - вычислить суммы по помеченным и всем записям

CTRL+R,F12 - выполнить расчет раскроя.

При вводе данных:

F2 - сохранить изменение

ESC - отказ от изменений.

Для сортировки по любой из колонок таблицы:

левой кнопкой мыши - нажать на серый текст заголовка колонки.


Листы на складе

В этот справочник можно занести листы материала, которые есть на складе.

Эти листы будут автоматически добавлены в задание на раскрой (по раскраиваемому типу материала) только в двух случаях:

1) в момент занесения пользователем самого первого листа в разделе “Листы ”;

2) в момент расчета карт раскроя - если ни одного листа по этому типу материала введено не было.

Для занесения реального числа листов на складе и автоматического учета программой - числа оставшихся листов (после получения карт раскроя):

1) из верхнего меню “Сервис” -> “Настройки” в подразделе ЛИСТЫ НА СКЛАДЕ измените настройку:

Вводить количество листов на складе -> Да.

2) задайте реальное число листов.

Если занесенные в этом справочнике листы уже закончились на складе, то просто удалите их.

Изменение или удаление листов в этом справочнике - никак не повлияет на другие данные.

Однако помните:

что в случае, если ранее было задано реальное число листов на складе и по ним были получены карты раскроя - то удаление такого листа приведет к потере возможности автоматического учета количества этих листов на складе при перерасчете карт раскроя.

По этой причине до тех пор, пока учет количества листов на складе все еще необходим:

вместо удаления листа - рекомендуется задать нулевое число листов.

Задаваемые размеры листа и кромки

Длина, ширина листа - это длина (по оси X), выcота (по оси Y) листа.

При задании кромок - имеется в виду прижатие заготовок к левому нижнему углу листа, то есть:

кромка слева - это нижняя кромка по оси X

кромка справа - это верхняя кромка по оси X

кромка снизу - это нижняя кромка по оси Y

кромка сверху - это верхняя кромка по оси Y.

Описание функциональных клавиш:

ENTER - редактировать запись

INSERT - добавить новую запись

F3 - продолжить поиск, начатый по F7

F6 - фильтр

F7 - поиск первой записи

F8 - удалить запись

ESC - выход.

При вводе данных:

F2 - сохранить изменение

ESC - отказ от изменений.

Фильтр отменяется клавишей F6

нажатием кнопки "Отменить фильтр".


Справочник материалов

Наименования всех типов материалов заносятся в этот справочник. При изменении существующего наименования материала - это название будет изменено во всех введенных данных . При попытке удалить наименование материала:

1) сначала будет выполнена проверка на наличие существующих по нему данных;

2) в случае если таких данных еще не существует - появится вопрос об удалении.

Описание функциональных клавиш:

ENTER - редактировать запись

INSERT - добавить новую запись

F8 - удалить запись

ESC - выход из Справочника.

При вводе данных:

F2 - сохранить изменение

ESC - отказ от изменений.